[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Scheme names

When is said that I thought one armed IF is a bad idea,
I really meant that having both a one armed IF and a two
armed IF called the same thing is a bad idea.  I can
live without one armed IF because it is trivial to write
the obvious WHEN macro or use COND.  Kent points out that the same
problem occurs with named LET.  Thus I withdraw my support
for named LET syntax, and request ITERATE (maybe called LOOP)
become an essential form.

I would like to echo KMP's statements about regularization of
naming in T.  It is great!  Even with a small programming language
like Scheme, it should be the case that one needs to memorize a
small set of naming rules, from which one can correctly guess the
name of the particular function of interest.  With T, I am noticely
less dependent on having a manual by my side.

I find it hard to believe that no standardization of macros is
attempted by the Scheme Report, and hope that KMP's macro suggestion
is given serious consideration.