[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

proposals for R5RS (sorry)


I see nothing particularly wrong with named let.  Gratuitously
changing names of constructs used by almost everyone cannot be 
a high priority item.  All it can do is cause trouble.  The 
perceived benefit of any such change is microscopic.

I still smart from the change of SEQUENCE to BEGIN.  I cannot think 
of a more awful choice than BEGIN.  We could have used SEQUENTIALLY
(by contrast to IN-PARALLEL), or something like that.