[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Name for BABY-DOE should not include "values".

I prefer a name for BABY-DOE which does not include the word "values".
The reason is that I believe such names are misleading.  In my
opinion, BABY-DOE gives me a way of creating an unusual continuation
to be used during a call of a thunk.  It is unusual because it splices
in a call of a procedure into the current continuation.  The important
fact about BABY-DOE is not that it calls a procedure with some values.
Please verify my point by studying the formal semantics.

Unfortunately, I have not yet come up with a good alternative name.
Here are some of my current tries:






CPS-CALL for "Continuation Passing Style CALL"