[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
mapcar and mapc
In response to Will Clinger's acceptance of the "mapc" -> "for-each"
How about renaming "mapc" to "mapcar!" (and thence to "map!")?
This would change the meaning of the bang notation from "Hi! I'm a
side-effecting function" to "Hi! I'm expecting either myself or one of the
functions that I call to be a side-effecting function".
This way, the two very simular functions "map" and "map!" keep simular
names, making life easier on the frail memory of the user.